Problema-Diagnostico. comando ip pim spt-threshold no funciona en Switches.

Practicando el escenario de pim en modo sparse, el RP se convierte en el árbol donde todos los originadores de multicast deben consultar para buscar los clientes de esa dirección multicast específica. Luego que el tráfico multicast le llega al primero router cercano en la solicitud de este tráfico, tratan por defecto, de realizar un SPT directo con el origen y desligarse del árbol RP, activando el bit SPT. El comando ip pim spt-threshold puede modificar este comportamiento por ancho de banda y para un grupo específico:

ip pim [vrf vrf-name] spt-threshold {kbps | infinity} [group-list access-list]

Este comando no funciona muy bien en los Switches 3560 que tenemos y por lo que he leído por ahí tambien le sucede a los 3550. El escenario es como sigue:

topologyr.jpg

El router R5 es el originador de multicast y el RP, mientras que el SW2 y R6 son equipos con clientes. Solo responde R6, pero no SW2 con el spt threshold activado.

Los síntomas son los siguientes y en este orden:

  1. activar el comando ip pim spt-threshold 256
  2. Asociar una interfaz a un grupo multicast con ip igmp join-group 225.5.5.5, Por ejemplo.

Asumamos que el origen y los receptores pueden asociarse sin ningún problema al RP. Si se observa los caminos multicast, todo parece estar en orden, pero al realizar ping a la dirección multicast no responde.

Para solucionarlo se debe realizar los siguientes pasos:

  1. eliminar el comando ip pim spt-threshold 256
  2. desasociar y asociar nuevamente las direcciones multicast que requieren verificarse.

Este escenario no sucede con los routers, solo con los switches.

Referencias:
http://ieoc.com/forums/p/14510/127539.aspx
http://ieoc.com/forums/t/7382.aspx

Unless otherwise stated, the content of this page is licensed under Creative Commons Attribution-ShareAlike 3.0 License